[SOLVED] Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Forum rules
Before you post please read this
Post Reply
Jinxed
Level 1
Level 1
Posts: 5
Joined: Thu Apr 02, 2020 1:01 pm

[SOLVED] Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Post by Jinxed »

Hi!

I'm running my Linux Mint on a NUC with integrated Intel® Iris® Plus Graphics 655. Unfortunately the only drivers provided on the Intel page are for Windows, searching for drivers didn't yield promising results either. An Intel page about Linux drivers linked to "https://01.org/linuxgraphics" but the newest release there is older than the manufacturing date of the NUC.

Therefore (I guess) VirtualBox is unable to provide an emulated guest systems with a GUI.

Unfortunately I don't know how to derive a linux driver from a windows driver (if that is possible, especially since I try to harden my distribution as best I can, which means I am not using wine or mono).

Help would be very much appreciated.
Thank you!
Last edited by Jinxed on Thu Apr 02, 2020 6:34 pm, edited 1 time in total.
User avatar
Colson P
Level 3
Level 3
Posts: 158
Joined: Mon Mar 23, 2020 5:33 pm

Re: Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Post by Colson P »

From my experience, using VirtualBox usually requires you to enable a "Virtualization" setting in your BIOS, not installing graphics drivers. For your Intel NUC, you need to access the BIOS by continually pressing F2 while booting. Once you get into the BIOS, use the arrow keys to find your Virtualization setting and try to enable it.
Linux in a nutshell: xkcd https://xkcd.com/619/

Always remember to marked your posts as [SOLVED] when your problem has been resolved.
That way, others can use your post to solve their own problems.
Jinxed
Level 1
Level 1
Posts: 5
Joined: Thu Apr 02, 2020 1:01 pm

Re: Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Post by Jinxed »

Unfortunately I could not find any dedicated "Virtualization" setting. Searched thoroughly, twice.
User avatar
Colson P
Level 3
Level 3
Posts: 158
Joined: Mon Mar 23, 2020 5:33 pm

Re: Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Post by Colson P »

Okay. The next step is to see if your NUC supports virtualization. Can you go here:
https://ark.intel.com/content/www/us/en ... l%C2%AENUC
and try to find your specific NUC? The specification page should tell you if it supports virtualization or not, down in the "Advanced Technologies" section of the page.
Linux in a nutshell: xkcd https://xkcd.com/619/

Always remember to marked your posts as [SOLVED] when your problem has been resolved.
That way, others can use your post to solve their own problems.
Jinxed
Level 1
Level 1
Posts: 5
Joined: Thu Apr 02, 2020 1:01 pm

Re: Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Post by Jinxed »

It says:

Intel® Virtualization Technology for Directed I/O (VT-d) - YES
Intel® Virtualization Technology (VT-x) - YES
User avatar
Colson P
Level 3
Level 3
Posts: 158
Joined: Mon Mar 23, 2020 5:33 pm

Re: Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Post by Colson P »

I forgot that "Virtualization" in an Intel BIOS is actually called "Intel VT" or "Intel VT-x", sorry about that.
Does that setting exist in your BIOS?
https://www.howtogeek.com/213795/how-t ... firmware/
Linux in a nutshell: xkcd https://xkcd.com/619/

Always remember to marked your posts as [SOLVED] when your problem has been resolved.
That way, others can use your post to solve their own problems.
Jinxed
Level 1
Level 1
Posts: 5
Joined: Thu Apr 02, 2020 1:01 pm

Re: Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Post by Jinxed »

Oh Yeah, its right there, oh my... now feel kinda stupid, after writing "looked thorougly, twice". But its listed under "security", didn't read that well enough. Anyway it is (and therefore probably was) enabled. I tried again, just to be sure. Same problem, I see the vm start and as soon as a GUI should pop up it is just black.
Jinxed
Level 1
Level 1
Posts: 5
Joined: Thu Apr 02, 2020 1:01 pm

Re: [SOLVED] Intel Iris Plus Graphics 655 Drivers for 19.3 Cinnamon

Post by Jinxed »

I found out what f*** the vm. It was a setting called "Enable nested paging". I unchecked it and switched "Paravirtualization Interface" from "Default" to "Hyper-V". Now it works!

Thank you very much for your Input Colson!
Post Reply