Weird dual screen display artefacts and mouse flickering

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Moltenhead
Level 1
Level 1
Posts: 5
Joined: Fri May 22, 2020 4:30 am

Weird dual screen display artefacts and mouse flickering

Post by Moltenhead »

Hi,

Here is a pastbin of inxi result : inxi inf.

I have a MB169B+ screen which I'm trying to use on my setup. I've successfully installed DIsplayLink Driver (version 5.2.4 since 5.3.0.28 was not working).
But now, when I go to Settings > Display and activate any form of dual screen (laptop monitor as main or the MB169B+ as main), I get those very weird visual glitch:
  • Mouse icon flickers and sometimes appear with a non alpha background reminiscent of previous element that was behind the mouse(text, colors, forms, ...)
  • Moving the mouse on some windows will produce artefacts of previous position of the mouse - leaving kind of a discontinuous trail of mouse icons - those artefacts are flickering also
  • The previous is also true if I move the mouse out of a window. Those artefacts will get produced not on the window itself, but on anything which is behind for more or less 1 or 2 seconds
  • clicking on some window elements or on the desktop will clear the existing artefacts
  • moving the cursor with arrows keys within this topic edition is triggering the flicker for every-time the cursor moved (accelerating the flickering)
Any idea about how to fix this thing ?

EDIT : Here are some urls to gifs showing what is happening :
Within forum editor
In and out of windows
Last edited by Moltenhead on Sat May 23, 2020 1:50 pm, edited 6 times in total.

User avatar
MrEen
Level 19
Level 19
Posts: 9765
Joined: Mon Jun 12, 2017 8:39 pm

Re: Weird dual screen display artefacts and mouse twitching displacement

Post by MrEen »

Hi Moltenhead, and welcome to the forum.

I suck at helping with graphics issues, but noticed a pertinent detail missing in your inxi output. Only one monitor was connected:
Graphics:
Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:3ea0
Device-2: AMD Jet PRO [Radeon R5 M230] vendor: Dell driver: N/A
bus ID: 01:00.0 chip ID: 1002:6665
Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics (Whiskey Lake 3x8 GT2)
v: 4.5 Mesa 19.2.8 compat-v: 3.0 direct render: Yes
Did you possibly run inxi while the MB169B+ wasn't connected?

This also ignores the fact there's no driver loaded for the Radeon card. Not sure if that's also an issue.

Moltenhead
Level 1
Level 1
Posts: 5
Joined: Fri May 22, 2020 4:30 am

Re: Weird dual screen display artefacts and mouse flickering

Post by Moltenhead »

You are right I did it without dual screen setup. Here is the Graphics part with it :
Graphics: Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0
Device-2: Advanced Micro Devices [AMD/ATI] Jet PRO [Radeon R5 M230] vendor: Dell driver: N/A bus ID: 01:00.0
chip ID: 1002:6665
Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics (Whiskey Lake 3x8 GT2) v: 4.5 Mesa 19.2.8 compat-v: 3.0
direct render: Yes
And I was unable to install a proper driver for my GPU yet ... this R5 M230 seems to be kind of trouble for lots of linux users.

EDIT : tried to reinstall fglrx with success this time, my driver manager is giving me choice between xserver-xorg-ati or fglrx now, fglrx is checked but even after couple reboots inxi is still saying the GPU has no driver.

User avatar
MrEen
Level 19
Level 19
Posts: 9765
Joined: Mon Jun 12, 2017 8:39 pm

Re: Weird dual screen display artefacts and mouse flickering

Post by MrEen »

Did you try the ati driver? Like I said, I suck at these issues, but I think fglrx doesn't work on anything after Mint 17.x/Ubuntu 14.04.

Moltenhead
Level 1
Level 1
Posts: 5
Joined: Fri May 22, 2020 4:30 am

Re: Weird dual screen display artefacts and mouse flickering

Post by Moltenhead »

Got back to the ati one anyway : had trouble with some apps with fglrx. But still : neither get referenced within inxi report and neither correct the graphical glitch - and that's with a couple reboots already.

User avatar
MrEen
Level 19
Level 19
Posts: 9765
Joined: Mon Jun 12, 2017 8:39 pm

Re: Weird dual screen display artefacts and mouse flickering

Post by MrEen »

Gotcha. We'll need to wait for proper graphics help.

Post Reply

Return to “Hardware Support”