(Solved) Unable to configure open.vpn, getting Option errors.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
E1-Beard-0
Level 3
Level 3
Posts: 178
Joined: Tue Feb 20, 2018 5:50 pm
Location: Michiana [North central Indiana]

(Solved) Unable to configure open.vpn, getting Option errors.

Post by E1-Beard-0 »

Greetings and Salutations all.

I’m unable to configure open.vpn, I'm getting Option errors.

I’m using Private Tunnel and I’ve downloaded a profile.
Private Tunnel’s instructions after you’ve obtained a profile are as follows:

Afterwards, use the following command: sudo openvpn --config "path to your .ovpn file"
where path to your .ovpn file refers to the file you have saved from our profile download site, such as "/home/ubuntu/San Jose.ovpn".

Code: Select all

cowser@cowser-Z370XP-SLI:~$ sudo openvpn --config /home/cowser/DNS_VPN/”City, State”.ovpn [Where ”City, State”.ovpn stands for the actual City and State.]
Options error: Unrecognized option or missing or extra parameter(s) in [CMD-LINE]:1: config (2.4.4)
Use --help for more information.

cowser@cowser-Z370XP-SLI:~$ locate ”City, State”.ovpn
/home/cowser/DNS_VPN/”City, State”.ovpn
Please note: I have two Gigabite Z370XP-SLI mother board based machines, with the same CPU, they both give similar error messages.

Here is the output of running the inxi -Fxz command:

Code: Select all

cowser@cowser-Z370XP-SLI:~$ inxi -Fxz
System:
  Host: cowser-Z370XP-SLI Kernel: 5.3.0-53-generic x86_64 bits: 64 
  compiler: gcc v: 7.5.0 Desktop: Xfce 4.14.1 Distro: Linux Mint 19.3 Tricia 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Gigabyte product: Z370XP SLI v: N/A serial: <filter> 
  Mobo: Gigabyte model: Z370XP SLI-CF v: x.x serial: <filter> 
  UEFI [Legacy]: American Megatrends v: F8 date: 07/05/2018 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 30% 
  status: Discharging 
CPU:
  Topology: 6-Core model: Intel Core i5-8600K bits: 64 type: MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 43200 
  Speed: 800 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 801 5: 801 6: 801 
Graphics:
  Device-1: Intel vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 19.2.8 direct render: Yes 
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.3.0-53-generic 
Network:
  Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:1f.6 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 37.43 GiB (8.0%) 
  ID-1: /dev/sda vendor: SK Hynix model: HFS500G32TND-N1A2A size: 465.76 GiB 
Partition:
  ID-1: / size: 455.77 GiB used: 37.12 GiB (8.1%) fs: ext4 dev: /dev/dm-1 
  ID-2: /boot size: 703.5 MiB used: 312.1 MiB (44.4%) fs: ext4 
  dev: /dev/sda1 
  ID-3: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-2 
Sensors:
  System Temperatures: cpu: 31.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 217 Uptime: 48m Memory: 7.65 GiB used: 1.03 GiB (13.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32
Thanks to those who choose to read this inquiry, a special thanks to those who choose to make a reply. Please feel free to make any requests for further information, if you do so, please be explicit, as I don’t necessarily know the significance of the various terms. Please be patient with me as I’m a bit slow on the uptake and often need clarification.

Thank you and respectfully yours E1-Beard-0
Last edited by E1-Beard-0 on Sun May 24, 2020 3:50 pm, edited 1 time in total.

gittiest personITW
Level 7
Level 7
Posts: 1873
Joined: Tue May 28, 2019 4:27 pm

Re: Unable to configure open.vpn, getting Option errors.

Post by gittiest personITW »

You can try using Network Manager to do the dirty work for you.
I posted instructions here:
viewtopic.php?f=157&t=319926

E1-Beard-0
Level 3
Level 3
Posts: 178
Joined: Tue Feb 20, 2018 5:50 pm
Location: Michiana [North central Indiana]

Re: (Solved) Unable to configure open.vpn, getting Option errors.

Post by E1-Beard-0 »

Greetings Denizens of the LM Forums,

I am a dummy and I just proved it once again.

I also was in communication with support at Private Tunnel, it seems that I should have included the quotation marks in the the command string. Once I went back and added the quotation marks to the config command string per PT's instructions, the configuration sequence completed successfully.

Please feel free to have a good laugh at my expense if so inclined.

Thank you and respectfully yours, E1-Beard-0

Post Reply

Return to “Newbie Questions”