impossible de masquer le menu grub au démarrage (résolu)

French Forum

Moderator: Laurent85

Post Reply
Hel
Level 1
Level 1
Posts: 22
Joined: Tue Oct 03, 2017 12:10 pm

impossible de masquer le menu grub au démarrage (résolu)

Post by Hel »

Bonjour,

j'ai récemment ré-installer Linux Mint 19.3 Tricia de manière à utiliser deux disques dur avec LVM, pas de dual boot avec un autre SE.

J'avais un problème : le système ne s'arrêtait pas toujours complètement normalement.

Pas de mise à jour possible du bios.

J'ai tenté quelques petites modifications de /etc/default/grub

Le système s'arrête complètement à chaque fois depuis, même en revenant aux paramètres par défaut.
Par contre le menu grub s'affiche à chaque démarrage avec un compte à rebours de 30 sec et ce quelles que soient les options.
Est-ce que cela indique un arrêt précédent anormal ?
J'ai même essayé de ré-installer grub et cette mystérieuse commande :

Code: Select all

grub-editenv create
mais le menu continu de s'afficher à chaque fois. Auriez-vous une suggestion svp ?
Last edited by Hel on Mon Jun 15, 2020 10:39 am, edited 1 time in total.

Laurent85
Level 16
Level 16
Posts: 6862
Joined: Tue May 26, 2015 10:11 am

Re: impossible de masquer le menu grub au démarrage

Post by Laurent85 »

Bonjour,
Edite le fichier de configuration /etc/default/grub avec :

Code: Select all

xed admin:/etc/default/grub
Modifie la ligne suivante :

Code: Select all

GRUB_TIMEOUT_STYLE="hidden"
Les valeurs possibles sont hidden, menu, countdown.
La ligne GRUB_TIMEOUT=10 correspond à la temporisation en secondes avant démarrage.

Finalement mets à jour grub avec :

Code: Select all

sudo update-grub
Image

Hel
Level 1
Level 1
Posts: 22
Joined: Tue Oct 03, 2017 12:10 pm

Re: impossible de masquer le menu grub au démarrage

Post by Hel »

Bonjour,

merci de ta réponse, mon fichier : /etc/default/grub contient déjà les valeurs suivantes :

Code: Select all

GRUB_DEFAULT="0"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="0"
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="acpi=force"
GRUB_CMDLINE_LINUX=""
j'ai déjà essayé avec d'autres paramètres comme :

Code: Select all

GRUB_TIMEOUT_STYLE="menu"
GRUB_TIMEOUT="5"
mais le menu s'affiche à chaque démarrage pendant 30 secondes.

je teste "acpi=force" parce que le problème d'extinction est réapparu une fois entre temps. Et j'ai retiré "quiet splash" pour voir un peu ce qui se passe.

cordialement
Last edited by Laurent85 on Mon Jun 08, 2020 7:34 am, edited 1 time in total.
Reason: Code tags

Laurent85
Level 16
Level 16
Posts: 6862
Joined: Tue May 26, 2015 10:11 am

Re: impossible de masquer le menu grub au démarrage

Post by Laurent85 »

Quel est le retour de ces commandes :

Code: Select all

sudo os-prober
sudo grub-probe /boot
cat /boot/grub/grubenv
grep -v -e '^#' -e '^$' /etc/default/grub
Envoie le fichier de configuration sur un pastebin avec cette commande, donne le lien obtenu :

Code: Select all

curl -F 'sprunge=<-' http://sprunge.us < /boot/grub/grub.cfg
Edition: correction du nom de fichier
Last edited by Laurent85 on Mon Jun 08, 2020 3:13 pm, edited 1 time in total.
Reason: Typo
Image

Hel
Level 1
Level 1
Posts: 22
Joined: Tue Oct 03, 2017 12:10 pm

Re: impossible de masquer le menu grub au démarrage

Post by Hel »

Voici le retour des commandes :

Code: Select all

$ sudo os-prober
$ sudo grub-probe /boot
ext2
$ cat /boot/grub/grubenv
# GRUB Environment Block
################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################
Il n'y a pas de fichier : '/boot/grub/grub.conf' j'ai pris : '/boot/grub/grub.cfg' qui doit être le bon fichier.

http://sprunge.us/6In183

j'ai remarqué ceci dans le fichier :

Code: Select all

if [ $grub_platform = efi ]; then
  set timeout=30
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
  fi
fi
Cela semble justifier le fonctionnement de grub au démarrage, grub est installé sur une partition EFI. Ce qui est bizarre, c'est que je suis à peu près sûr que grub ne faisait pas ça avant que j'essaie de régler le problème d'extinction.

PS: j'ai remis : "quiet splash" à la place de "acpi=force" et je suis passé sur un kernel 4.15 pour voir si le pc s'éteint mieux.

Laurent85
Level 16
Level 16
Posts: 6862
Joined: Tue May 26, 2015 10:11 am

Re: impossible de masquer le menu grub au démarrage

Post by Laurent85 »

C'est le comportement normal de grub avec lvm d'après ce commentaire :
function recordfail {
set recordfail=1
# GRUB lacks write support for lvm, so recordfail support is disabled.
}
...
if [ "${recordfail}" = 1 ] ; then
set timeout=30
Image

Hel
Level 1
Level 1
Posts: 22
Joined: Tue Oct 03, 2017 12:10 pm

Re: impossible de masquer le menu grub au démarrage

Post by Hel »

Ah bon d'accord, il n'y a rien à faire alors... Merci !

Hel
Level 1
Level 1
Posts: 22
Joined: Tue Oct 03, 2017 12:10 pm

Re: impossible de masquer le menu grub au démarrage

Post by Hel »

Petit épilogue,
j'ai tenté de remplacer GRUB par rEFInd, ce qui m'a permis de casser définitivement le démarrage de Mint. Puis, je n'ai pas réussi à réparer GRUB avec l'outil de réparartion de la live USB.
Finalement, j'ai ré-installer la partition système en conservant mes fichiers personnels, ce qui réinstalle un nouveau GRUB fonctionnel au passage et reste la solution la plus simple.
J'ai fait toutes les mises à jours et pourtant je n'ai plus jamais eu de problème d'extinction depuis. J'ai juste à attendre 30 secondes ou a appuyer sur Entrée au démarrage. Comme quoi, le mieux est (parfois) l'ennemi du bien.

Post Reply

Return to “Français (French)”