GPU Sound Controller not Detected After Screen Power Off

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Aryanprince
Level 1
Level 1
Posts: 10
Joined: Mon Jun 29, 2020 8:11 am

GPU Sound Controller not Detected After Screen Power Off

Post by Aryanprince »

Hello. I am using LM20 and listening to the sound via HDMI cable connected to my GPU and Monitor. Everything is working perfectly fine until due to inactivity my screen turns off (atm it is set to 30min in LM settings). After that, when I come back to my PC, and move mouse in order to turn on the screen, there is no sound. Infact, in sound settings the LM does not recognize the HDMI device from my GPU, it only lists my onboard sound device, to which no speakers are connected. So I have to restart my PC. After restard everything is working fine again.

I am running nVidia GTX1070 with propriatary driver 450.80.02.

I know its not a major issue, but it drives me crazy sometimes, and if I plan to go away from my PC, I shut it down in order not to wait the restarting when I come back.

Thanks.
User avatar
MrEen
Level 22
Level 22
Posts: 15272
Joined: Mon Jun 12, 2017 8:39 pm

Re: GPU Sound Controller not Detected After Screen Power Off

Post by MrEen »

Hi Aryanprince,

Some things you could try instead of rebooting are mentioned in this thread: viewtopic.php?f=90&t=333034

Let us know if anything there improves things for you.
Aryanprince
Level 1
Level 1
Posts: 10
Joined: Mon Jun 29, 2020 8:11 am

Re: GPU Sound Controller not Detected After Screen Power Off

Post by Aryanprince »

Thank you. The command pulseaudio -r fixes the issue. Is there a way to make it permanent?
User avatar
MrEen
Level 22
Level 22
Posts: 15272
Joined: Mon Jun 12, 2017 8:39 pm

Re: GPU Sound Controller not Detected After Screen Power Off

Post by MrEen »

There probably is, but it'll depend on exactly what is happening. I assume the computer is suspending due to inactivity. That means you have 3 choices as I see it:

1. Stop the computer from suspending, and just use screen blanking.

2. Create a simple keyboard shortcut to hit right after you resume that invokes pulseaudio -k

3. This one is trickier. See the stuff I posted here. You'll need to change the use of fred to your username, and use this command instead of the one with gksudo:

Code: Select all

xed admin:///etc/systemd/system/resume-fix-pulseaudio@.service
And just to drive it home, the last step will be this:
Save that file and close it, then back in the terminal type systemctl enable resume-fix-pulseaudio@YOURUSERNAMEGOESHERE.service, followed by systemctl --system daemon-reload, changing the text YOURUSERNAMEGOESHERE to your actual username.
Post Reply

Return to “Sound, Multimedia, & Codecs”