<SOLVED> Mint 20.1 Installer Hangs After Media Codecs Screen

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Tue Feb 23, 2021 12:20 pm

<SOLVED> Mint 20.1 Installer Hangs After Media Codecs Screen

Post by dasails »

I'm trying to install 20.1 Cinnamon from USB stick, over the current 18.3 dual boot installation I've been using with very few issues for years. In the past, I've worked through issues on a handful of other PCs to successfully install 18.3 and earlier versions many times. But despite working though every seemingly relevant tip I have found so far, I can't get the 20.1 installer to get beyond the Media Codecs screen.

Linux Mint 20.1 Live boots and works well from USB stick. From Live, the Installer moves quickly through language and keyboard selection to Media Codecs, then, whether or not I check the install codecs box and continue, the little "processing" circle appears and remains until I force quit -- as much as a half hour later.

You will note, in the inxi -Fxxxrz and parted -l results below, that the target PC is a relatively capable and not very old Dell XPS desktop with SDD and two HDDs. Win 10 is the factory installed dual boot alternative. Win 10 is almost never used, but I'm not prepared to dump it entirely. Mint 18.3 root is mounted on the SDD (/dev/sda5) and /home on the first HDD (/dev/sdb2). The intent is to put 20.1 down in these same partitions.

Some of the approaches tried and failed (all with the same result):

1. Media Codecs: Tried both checking the install codecs box and not checking it.
2. Boot: Secure boot is off. USB stick with Live has been tried booted in UEFI mode and also in Legacy mode.
3. Disconnecting HDDs: I've run the installer with all three drives (SDD + HDD1 + HDD2), with SDD + HDD1 only, and with SDD alone. (Don't be confused by the second HDD with linux type partitions. It's from an older PC and mounted only on occasion for access to older data or to store backups. And 20.1 installer doesn't behave differently when its not there.)
4. ISO and USB stick: I've downloaded 20.1 ISO and created USB stick twice, through the entire process, including ISO checksums and USB media integrity check on boot.

Help is clearly needed and will be much appreciated.

inxi -Fxxxrz

Code: Select all

$ inxi -Fxxxrz
System:    Host: djan3-XPS-8930 Kernel: 4.15.0-133-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell product: XPS 8930 v: 1.1.16 Chassis: type: 3
           Mobo: Dell model: 0DF42J v: A00
           Bios: Dell v: 1.1.16 date: 01/06/2021
CPU:       Hexa core Intel Core i7-8700 (-HT-MCP-) cache: 12288 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 38399
           clock speeds: min/max: 800/4600 MHz 1: 3614 MHz 2: 3400 MHz
           3: 3806 MHz 4: 3960 MHz 5: 3889 MHz 6: 3994 MHz 7: 3976 MHz
           8: 3981 MHz 9: 3700 MHz 10: 3691 MHz 11: 3725 MHz 12: 3701 MHz
Graphics:  Card-1: Intel Device 3e92 bus-ID: 00:02.0 chip-ID: 8086:3e92
           Card-2: NVIDIA GP107 [GeForce GTX 1050 Ti]
           bus-ID: 01:00.0 chip-ID: 10de:1c82
           Display Server: X.Org 1.18.4 drivers: nvidia,intel (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 1050 Ti/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GP107GL High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0fb9
           Card-2 Intel 200 Series PCH HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-133-generic
Network:   Card-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 03:00.0 chip-ID: 168c:0042
           IF: wlp3s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 04:00.0 chip-ID: 1969:e0a1
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-3: Atheros usb-ID: 001-004 chip-ID: 0cf3:e009
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 2256.5GB (9.6% used)
           ID-1: /dev/sda model: SPCC_Solid_State size: 256.1GB serial: AA000000000000000638
           ID-2: /dev/sdb model: TOSHIBA_DT01ACA1 size: 1000.2GB serial: 97R1AD4MS
           ID-3: /dev/sdc model: ST1000DM010 size: 1000.2GB serial: Z9A7Y0PM
Partition: ID-1: / size: 39G used: 19G (51%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 459G used: 169G (39%) fs: ext4 dev: /dev/sdb2
           ID-3: swap-1 size: 17.00GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Parted -l

Code: Select all

$ sudo parted -l
[sudo] password for djan3: 
Model: ATA SPCC Solid State (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  524MB  523MB   ntfs         Basic data partition          hidden, diag
 2      524MB   629MB  105MB   fat32        EFI system partition          boot, esp
 3      629MB   646MB  16.8MB               Microsoft reserved partition  msftres
 4      646MB   132GB  131GB   ntfs         Basic data partition          msftdata
 5      132GB   174GB  41.9GB  ext4

Model: ATA TOSHIBA DT01ACA1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                  Flags
 1      1049kB  237GB   237GB   ntfs            Basic data partition  msftdata
 2      237GB   737GB   500GB   ext4
 3      983GB   1000GB  17.0GB  linux-swap(v1)

Model: ATA ST1000DM010-2EP1 (scsi)
Disk /dev/sdc: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  512MB   511MB   primary   ext2            boot
 2      512MB   25.5GB  25.0GB  primary   ext4
 3      25.5GB  30.5GB  5000MB  primary   linux-swap(v1)
 4      30.5GB  531GB   500GB   extended
 5      30.5GB  531GB   500GB   logical   ext4
Last edited by dasails on Tue Mar 16, 2021 12:58 pm, edited 1 time in total.
User avatar
Level 13
Level 13
Posts: 4852
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Mint 20.1 Installer Hangs After Media Codecs Screen

Post by SMG »

This is thread about an older version of Mint Install Hangs at "install 3rd Party" Screen, but maybe something in it might give you some ideas.

We recommend that the root partition for LM20 be 30-50GB when one has a separate /home, but yours is currently in that size range so that suggestion from that thread does not apply in your case.
A woman typing on a laptop with LM20.1 Cinnamon.
Level 1
Level 1
Posts: 2
Joined: Tue Feb 23, 2021 12:20 pm

[SOLVED} Re: Mint 20.1 Installer Hangs After Media Codecs Screen

Post by dasails »

Thank you for the response. I eventually discovered the problem and have 20.1 installed and running today.

The SSD was beginning to fail. The only functional symptom was that the PC would no longer boot into Windows 10.

Several tools helped sketch the outlines of the problem. Dell diagnostics flagged a problem with the drive. LM Preferences>Disks tool SMART analysis declared the SSD was failing. gParted partition check of the Win 10 partition (/dev/sda4) gave more specifics plus the recommendation to run chkdsk in Windows and reboot twice. I haven't succeeded yet at finding a way to run chkd, but I did get a new SSD and used Clonezilla Live to try to clone the old SSD to the new one. Clonezilla pointed to specific problems with the Win 10 sda4 partition and LM "/" partition (sda5). It couldn't fully complete the clone, but it did set up the five partitions. Windows 10 preboot recovery tools declared problems but could not fix them without a complete reinstall. Rather than mess with those issues, I stopped working with the old SSD for now and installed the new SSD and 20.1. There are a couple of application packages that stored program files in /opt on the SSD that I'll need to install later, but otherwise, everything is installed and running, and better than ever now that it's all on 20.1.
Post Reply

Return to “Installation & Boot”