[SOLVED] no access to the internet after using protonvpn

Questions about Wi-Fi and other network devices, file sharing, firewalls, connection sharing etc
Forum rules
Before you post please read how to get help
Post Reply
youyou54
Level 1
Level 1
Posts: 24
Joined: Sun Mar 14, 2021 6:41 am

[SOLVED] no access to the internet after using protonvpn

Post by youyou54 »

Hello all,
I installed protonvpn to try this, but it seems quite buggy atm and now i haven't access to the internet anymore (it's working on my other machines). Could you help me to sort this?
thanks :)

Code: Select all

  Desktop: Cinnamon 4.8.6 wm: muffin 4.8.1 dm: LightDM 1.30.0 
  Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop Mobo: Micro-Star model: MEG X570 ACE (MS-7C35) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.C0 date: 10/29/2020 
CPU:
  Topology: 12-Core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP 
  arch: Zen 3 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 177605 
  Speed: 2200 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 
  1: 2200 2: 2197 3: 2197 4: 2195 5: 2197 6: 2195 7: 2197 8: 2194 9: 2195 
  10: 2194 11: 2195 12: 2193 13: 2200 14: 2199 15: 2197 16: 2195 17: 2194 
  18: 2194 19: 2196 20: 2197 21: 2197 22: 2169 23: 2199 24: 2199 
Graphics:
  Device-1: NVIDIA driver: nvidia v: 460.73.01 bus ID: 2d:00.0 
  chip ID: 10de:2206 
  Display: x11 server: X.Org 1.20.9 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce RTX 3080/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 
  direct render: Yes 
Audio:
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus ID: 2d:00.1 
  chip ID: 10de:1aef 
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 2f:00.4 chip ID: 1022:1487 
  Sound Server: ALSA v: k5.8.0-53-generic 
Network:
  Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb 
  v: 5.6.0-k port: e000 bus ID: 26:00.0 chip ID: 8086:1539 
  IF: enp38s0 state: down mac: <filter> 
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 
  v: kernel port: d000 bus ID: 27:00.0 chip ID: 10ec:8125 
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: d000 
  bus ID: 28:00.0 chip ID: 8086:2723 
  IF: wlo1 state: down mac: <filter> 
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A 
  mac: <filter> 
  IF-ID-2: pvpnksintrf0 state: unknown speed: N/A duplex: N/A mac: <filter> 
  IF-ID-3: pvpnroutintrf0 state: unknown speed: N/A duplex: N/A 
  mac: <filter> 
Drives:
  Local Storage: total: 6.37 TiB used: 204.58 GiB (3.1%) 
  ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP600 size: 931.51 GiB 
  speed: 63.2 Gb/s lanes: 4 serial: <filter> rev: EGFM11.3 scheme: GPT 
  ID-2: /dev/nvme1n1 vendor: Corsair model: Force MP600 size: 931.51 GiB 
  speed: 63.2 Gb/s lanes: 4 serial: <filter> rev: EGFM13.0 
  ID-3: /dev/sda vendor: Western Digital model: WD4005FZBX-00K5WB0 
  size: 3.64 TiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: 1A01 temp: 33 C scheme: GPT 
  ID-4: /dev/sdb vendor: Crucial model: CT2000MX500SSD1 size: 1.82 TiB 
  speed: 6.0 Gb/s serial: <filter> rev: 033 temp: 33 C scheme: GPT 
Partition:
  ID-1: / size: 122.34 GiB used: 10.74 GiB (8.8%) fs: ext4 
  dev: /dev/nvme0n1p5 
  ID-2: /home size: 519.69 GiB used: 14.87 GiB (2.9%) fs: ext4 
  dev: /dev/nvme0n1p7 
  ID-3: swap-1 size: 29.80 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p6 
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 37 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://mirrors.evowise.com/linuxmint/packages ulyssa main upstream import backport
  2: deb http://mirrors.ircam.fr/pub/ubuntu/archive focal main restricted universe multiverse
  3: deb http://mirrors.ircam.fr/pub/ubuntu/archive focal-updates main restricted universe multiverse
  4: deb http://mirrors.ircam.fr/pub/ubuntu/archive focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
  Active apt repos in: /etc/apt/sources.list.d/phoerious-keepassxc-focal.list 
  1: deb http://ppa.launchpad.net/phoerious/keepassxc/ubuntu focal main
  Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
  1: deb [arch=amd64] https://repo.skype.com/deb stable main
  Active apt repos in: /etc/apt/sources.list.d/yannubuntu-boot-repair-focal.list 
  1: deb http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal main
  Active apt repos in: /etc/apt/sources.list.d/yubico-stable-focal.list 
  1: deb http://ppa.launchpad.net/yubico/stable/ubuntu focal main
Info:
  Processes: 404 Uptime: 24m Memory: 31.34 GiB used: 1.56 GiB (5.0%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 
Last edited by youyou54 on Fri May 28, 2021 11:32 pm, edited 1 time in total.
User avatar
Larry78723
Level 13
Level 13
Posts: 4936
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: no access to the internet after using protonvpn

Post by Larry78723 »

Which card were you using? You have 2 ethernet cards and a wifi card.
Image
youyou54
Level 1
Level 1
Posts: 24
Joined: Sun Mar 14, 2021 6:41 am

Re: no access to the internet after using protonvpn

Post by youyou54 »

The Realtek RTL8125

But i tried with the other one, it doesn't change anything

edit: no help with the wifi card neither
User avatar
Larry78723
Level 13
Level 13
Posts: 4936
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: no access to the internet after using protonvpn

Post by Larry78723 »

If you reboot, does the connection return?
Image
youyou54
Level 1
Level 1
Posts: 24
Joined: Sun Mar 14, 2021 6:41 am

Re: no access to the internet after using protonvpn

Post by youyou54 »

nope ...

I tried to reboot the machine, tried to reboot the box, reinitialized the box, changes Ethernet cable, purger all protonvpn packages .... no help
User avatar
Larry78723
Level 13
Level 13
Posts: 4936
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: no access to the internet after using protonvpn

Post by Larry78723 »

Your inxi reports that the RTL8125 is up. Please post the results of the following commands:

Code: Select all

mokutil --sb-state	

Code: Select all

rfkill list

Code: Select all

 ifconfig
Image
sleeper12
Level 17
Level 17
Posts: 7882
Joined: Thu May 25, 2017 3:22 pm

Re: no access to the internet after using protonvpn

Post by sleeper12 »

Also, try:

Code: Select all

 sudo modprobe -r r8169 && sudo modprobe r8169 
Or:

Code: Select all

 sudo service network-manager restart 
User avatar
hglee
Level 5
Level 5
Posts: 955
Joined: Fri Jun 22, 2018 4:31 pm

Re: no access to the internet after using protonvpn

Post by hglee »

youyou54 wrote:
Fri May 28, 2021 2:47 pm
Hello all,
I installed protonvpn to try this, but it seems quite buggy atm and now i haven't access to the internet anymore (it's working on my other machines). Could you help me to sort this?


If purging (then reinstalling) Proton isn't an option, try disabling its Kill Switch and autoconnect, or switch to a different relay.


Linux Mint 20.1 Ulyssa, MATE 1.24.0, kernel 5.11.0*-hwe, Dell 2-in-1
AMD Ryzen 7 4700U / Renoir GPU - 14" FHD WVA Touchscreen
Intel AX200 WiFi-6 BT-5.1; 32GB DDR4@3200MHz; 2TB XPG NVMe
youyou54
Level 1
Level 1
Posts: 24
Joined: Sun Mar 14, 2021 6:41 am

Re: no access to the internet after using protonvpn

Post by youyou54 »

Code: Select all

$ mokutil --sb-state 
SecureBoot disabled
Platform is in Setup Mode

Code: Select all

$ rfkill list
0: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Code: Select all

$ ifconfig
enp38s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:d8:61:a6:2c:cb  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfc800000-fc81ffff  

enp39s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.1  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2a01:e0a:185:cc20:cb48:bd0b:3ea5:7d2e  prefixlen 64  scopeid 0x0<global>
        inet6 2a01:e0a:185:cc20:3ad2:5a3e:509c:a8ac  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::b7a8:7ec8:c593:643  prefixlen 64  scopeid 0x20<link>
        ether 00:d8:61:a6:2c:ca  txqueuelen 1000  (Ethernet)
        RX packets 11353  bytes 2931065 (2.9 MB)
        RX errors 0  dropped 92  overruns 0  frame 0
        TX packets 3409  bytes 555902 (555.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

ipv6leakintrf0: flags=195<UP,BROADCAST,RUNNING,NOARP>  mtu 1500
        inet6 fdeb:446c:912d:8da::  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::2854:9932:f207:5d1a  prefixlen 64  scopeid 0x20<link>
        ether 9e:4c:98:2a:4f:b2  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1232  bytes 215870 (215.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 19263  bytes 1569483 (1.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 19263  bytes 1569483 (1.5 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

pvpnksintrf0: flags=195<UP,BROADCAST,RUNNING,NOARP>  mtu 1500
        inet 100.85.0.1  netmask 255.255.255.0  broadcast 100.85.0.255
        inet6 fdeb:446c:912d:8da::  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::1463:3f50:a634:244a  prefixlen 64  scopeid 0x20<link>
        ether 1a:a4:82:37:8a:3b  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3  bytes 126 (126.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

pvpnroutintrf0: flags=195<UP,BROADCAST,RUNNING,NOARP>  mtu 1500
        inet 100.85.0.1  netmask 255.255.255.0  broadcast 100.85.0.255
        inet6 fe80::350f:b591:1f2f:ddee  prefixlen 64  scopeid 0x20<link>
        inet6 fdeb:446c:912d:8da::  prefixlen 64  scopeid 0x0<global>
        ether da:d7:2f:0f:45:e1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4147  bytes 307018 (307.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
@hglee I don't have any instance of protonvpn running, and it is uninstalled. But maybe it modified something in my config files ? dunno :/
User avatar
hglee
Level 5
Level 5
Posts: 955
Joined: Fri Jun 22, 2018 4:31 pm

Re: no access to the internet after using protonvpn

Post by hglee »

youyou54 wrote:
Fri May 28, 2021 9:58 pm
Network:
IF-ID-2: pvpnksintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-3: pvpnroutintrf0 state: unknown speed: N/A duplex: N/A


@hglee I don't have any instance of protonvpn running, and it is uninstalled. But maybe it modified something in my config files ? dunno :/


Your inxi report data shows that you do have VPN code lurking in your system. Is Proton the only VPN you've ever installed?

You may need to reinstall -- then purge it.


Linux Mint 20.1 Ulyssa, MATE 1.24.0, kernel 5.11.0*-hwe, Dell 2-in-1
AMD Ryzen 7 4700U / Renoir GPU - 14" FHD WVA Touchscreen
Intel AX200 WiFi-6 BT-5.1; 32GB DDR4@3200MHz; 2TB XPG NVMe
youyou54
Level 1
Level 1
Posts: 24
Joined: Sun Mar 14, 2021 6:41 am

Re: no access to the internet after using protonvpn

Post by youyou54 »

i already purged protonvpn ...
I gave to reinstall it offline you mean? Will try
youyou54
Level 1
Level 1
Posts: 24
Joined: Sun Mar 14, 2021 6:41 am

Re: no access to the internet after using protonvpn

Post by youyou54 »

ok so i found how to sort this sh***

The output of

Code: Select all

ip a
shows 2 interfaces related to protonvpn that are not disabled, even when the protonvpn packages are purged ....

Code: Select all

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp39s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:d8:61:a6:2c:ca brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global dynamic noprefixroute enp39s0
       valid_lft 43181sec preferred_lft 43181sec
    inet6 2a01:e0a:185:cc20:5e4:4db9:eccc:4a0b/64 scope global temporary dynamic 
       valid_lft 86382sec preferred_lft 86008sec
    inet6 2a01:e0a:185:cc20:3ad2:5a3e:509c:a8ac/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86382sec preferred_lft 86382sec
    inet6 fe80::b7a8:7ec8:c593:643/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: enp38s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:d8:61:a6:2c:cb brd ff:ff:ff:ff:ff:ff
4: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 50:e0:85:85:1e:25 brd ff:ff:ff:ff:ff:ff
    altname wlp40s0
5: ipv6leakintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether 12:72:92:89:31:61 brd ff:ff:ff:ff:ff:ff
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::2854:9932:f207:5d1a/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
6: pvpnroutintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether f6:b6:c5:b2:b8:55 brd ff:ff:ff:ff:ff:ff
    inet 100.85.0.1/24 brd 100.85.0.255 scope global noprefixroute pvpnroutintrf0
       valid_lft forever preferred_lft forever
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::350f:b591:1f2f:ddee/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
7: pvpnksintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether fa:c5:f1:c6:6c:b7 brd ff:ff:ff:ff:ff:ff
    inet 100.85.0.1/24 brd 100.85.0.255 scope global noprefixroute pvpnksintrf0
       valid_lft forever preferred_lft forever
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::1463:3f50:a634:244a/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
interfaces 6 and 7 are related to protonvpn and should' be there as i purged the packages. So i disabled it with

Code: Select all

sudo ip link delete pvpn*
It made the internet come back

note the rebooting the machine makes the interfaces reappear .... probably because the uninstall packages of protonvpn are messy and the purge isn't done correctly ...

Btw, i reinstalled protonpvn and i disabled the "kill switch". It was the origin of the problem.

Hope this help ^^
User avatar
hglee
Level 5
Level 5
Posts: 955
Joined: Fri Jun 22, 2018 4:31 pm

Re: no access to the internet after using protonvpn

Post by hglee »

youyou54 wrote:
Fri May 28, 2021 11:31 pm
ok so i found how to sort this sh***

Btw, i reinstalled protonpvn and i disabled the "kill switch". It was the origin of the problem.

Uh-huh.


Linux Mint 20.1 Ulyssa, MATE 1.24.0, kernel 5.11.0*-hwe, Dell 2-in-1
AMD Ryzen 7 4700U / Renoir GPU - 14" FHD WVA Touchscreen
Intel AX200 WiFi-6 BT-5.1; 32GB DDR4@3200MHz; 2TB XPG NVMe
motoryzen
Level 6
Level 6
Posts: 1084
Joined: Sun Dec 08, 2019 12:25 am

Re: no access to the internet after using protonvpn

Post by motoryzen »

youyou54 wrote:
Fri May 28, 2021 11:31 pm
ok so i found how to sort this sh***

The output of

Code: Select all

ip a
shows 2 interfaces related to protonvpn that are not disabled, even when the protonvpn packages are purged ....

Code: Select all

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp39s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:d8:61:a6:2c:ca brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global dynamic noprefixroute enp39s0
       valid_lft 43181sec preferred_lft 43181sec
    inet6 2a01:e0a:185:cc20:5e4:4db9:eccc:4a0b/64 scope global temporary dynamic 
       valid_lft 86382sec preferred_lft 86008sec
    inet6 2a01:e0a:185:cc20:3ad2:5a3e:509c:a8ac/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86382sec preferred_lft 86382sec
    inet6 fe80::b7a8:7ec8:c593:643/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: enp38s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:d8:61:a6:2c:cb brd ff:ff:ff:ff:ff:ff
4: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 50:e0:85:85:1e:25 brd ff:ff:ff:ff:ff:ff
    altname wlp40s0
5: ipv6leakintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether 12:72:92:89:31:61 brd ff:ff:ff:ff:ff:ff
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::2854:9932:f207:5d1a/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
6: pvpnroutintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether f6:b6:c5:b2:b8:55 brd ff:ff:ff:ff:ff:ff
    inet 100.85.0.1/24 brd 100.85.0.255 scope global noprefixroute pvpnroutintrf0
       valid_lft forever preferred_lft forever
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::350f:b591:1f2f:ddee/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
7: pvpnksintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether fa:c5:f1:c6:6c:b7 brd ff:ff:ff:ff:ff:ff
    inet 100.85.0.1/24 brd 100.85.0.255 scope global noprefixroute pvpnksintrf0
       valid_lft forever preferred_lft forever
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::1463:3f50:a634:244a/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
interfaces 6 and 7 are related to protonvpn and should' be there as i purged the packages. So i disabled it with

Code: Select all

sudo ip link delete pvpn*
It made the internet come back

note the rebooting the machine makes the interfaces reappear .... probably because the uninstall packages of protonvpn are messy and the purge isn't done correctly ...

Btw, i reinstalled protonpvn and i disabled the "kill switch". It was the origin of the problem.

Hope this help ^^
:) Thanks for sharing that info. I have a friend who refuses to use the internet without a vpn who just hopped on Linux. This might prove useful for him. Cheers. congrats on solving the problem.
Post Reply