Page 1 of 1

System Report - USRMERGE

Posted: Mon Apr 01, 2024 7:20 pm
by yaklinux
My system reports notice is telling me I need to perform a "usrmerge". Photos attached. I've tried searching for this and it doesn't seem to be getting anywhere...

Terminal code I found that checks if the system has it already setup:

Code: Select all

$ ls -ld /bin /sbin /lib /libx32 /lib64 /lib32
ls: cannot access '/libx32': No such file or directory
lrwxrwxrwx 1 root root    7 Mar 16 20:08 /bin -> usr/bin
lrwxrwxrwx 1 root root    7 Mar 16 20:08 /lib -> usr/lib
drwxr-xr-x 2 root root 4096 Apr  1 19:08 /lib32
lrwxrwxrwx 1 root root    9 Mar 16 20:08 /lib64 -> usr/lib64
lrwxrwxrwx 1 root root    8 Mar 16 20:08 /sbin -> usr/sbin
Image

How do I fix this and why was it an issue in the first place?

Re: System Report - USRMERGE

Posted: Mon Apr 01, 2024 7:28 pm
by djph
"usrmerge" is an attempt by upstream developers / distros to "clean up(tm)" the filesystem.

There is a "usrmerge" package that would do this for you (which given your output "seems" to have been installed already). If it's not yet actually applied, given some troubles I've seen in Debian and Ubuntu; make sure you've got a timeshift snapshot before you apply it.

Re: System Report - USRMERGE

Posted: Mon Apr 01, 2024 7:34 pm
by zcot
I pull the blog entry, there is one roughly on the first of the month every month, with some additional ones as needed. This is from Jan 2020, but I do remember a blog post prior to this "how to upgrade" that introduced the idea anyway, I can't find it easily.

But there: https://blog.linuxmint.com/?p=4020

Re: System Report - USRMERGE

Posted: Tue Apr 02, 2024 6:48 pm
by yaklinux
It says this should be done for new installs already for a while. I just installed Mint a couple weeks ago. Why would this error be happening? Based on the terminal command I showed - the only folder which isn't "linked" is the lib32 folder. I tried moving the files but they won't move.

Re: System Report - USRMERGE

Posted: Fri Apr 12, 2024 10:28 am
by yaklinux
Anyone?

I still have a "lib32" folder with (files inside it) that doesn't have the arrow link on it. Running these usrmerge commands doesn't do anything. How do I know what is using that file/library?

Re: System Report - USRMERGE

Posted: Mon Apr 15, 2024 3:37 pm
by djph
/lib32 is 32bit libraries for 32bit applications. Chances are it's not a high priority, since 32bit is dead.

Re: System Report - USRMERGE

Posted: Mon Apr 15, 2024 9:24 pm
by zcot
if I'm not mistaken, but I might be, they were trying to drop 32 bit support for I believe it was the equivalent Mint 20(Ubuntu 20.04), but they drew back on that when a bunch of people freaked out absolutely. But for Mint 21(Ubuntu 22.04) I think ... ah, hell, I don't know if they did it one way or the other. I was thinking steam was using a base 32 bit support anyway, maybe just the steam base. And WINE is typically wanting to be very 32 bit-ready...

Let me be clear, I have no clue where everything stands.

BUT, clearly, whoever is running 32 bit-only hardware is in a bad situation, but to be true it's really not bad, that's severe legacy stuff and almost basically nobody even tries to use that dastardly setup anymore. And definitely the Ubuntu's/Mints have not supported a base 32 bit installed for at least more than 3 years, even though there may still be some minimal back support at least.

Sometimes it's better to go ahead and use it as a doorstop, when the literal usage condition is exactly that.

yaklinux, for your situation, perhaps your scenario has come about due to upgrades from previous version, or maybe some specific software situation, but should be nothing to be concerned about as long as we have status quo.

Re: System Report - USRMERGE

Posted: Tue Apr 16, 2024 6:11 am
by djph
Almost -- /lib32 is still used today when you need to pull in 32bit libraries (like for steam, or maybe an old printer, etc.)

Honestly, this need for 32bit libraries is going to hang around for a while still. I think it was only Windows 11 that finally murdered 16bit support in Windows land (and that died as hardware in the 80s)