Updating

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo »

Can you install applications via synaptic?

do you have a firewall setup on the pc?
the message is saying that it can not connect to port 4001 on your computer.
turn off the firewall and see if it works then.

what happens if you untick the rsync package in the updater and do an update?

:D
Image
Now where was i going? Oh yes, crazy!
scorp123
Level 8
Level 8
Posts: 2272
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Re: Updating

Post by scorp123 »

jdtexas wrote: Could not connect to localhost:4001 (127.0.0.1). - connect (111 Connection refused)
Could it be that you used your own host (= 127.0.0.1) as proxy somehow?
scorp123
Level 8
Level 8
Posts: 2272
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Re: Updating

Post by scorp123 »

jdtexas wrote:I checked to see if the 127.0.0.1 address was listed as a proxy. It was. I deleted it
So if you used your own host as a proxy so maybe you also used some sort of proxy process somewhere somehow in the past? e.g. 'squid' or something like that?

As I see it your problem is this:

For reasons you did not state yet you configured your own machine as proxy and you had it running on port 4001; hence all the package managers accessed their repos via this host:port combination. But now: Somehow you stopped the proxy from working, e.g. either by reconfiguring it or by removing it from your system. But your package managers are still pointing at the --now defunct-- proxy, hence you get this error message: "Could not connect to localhost:4001 (127.0.0.1). - connect (111 Connection refused)"

So as I see it you have to completely remove any remaining references to the proxy and access the repos (and everything else?) directly. Then it should work.
Post Reply

Return to “Newbie Questions”