Delete default bottom panel

Forum rules
Before you post please read how to get help
Post Reply
User avatar
kindofabuzz
Level 2
Level 2
Posts: 75
Joined: Fri Jan 30, 2009 7:47 am
Location: Memphis, TN

Delete default bottom panel

Post by kindofabuzz » Wed Jul 28, 2010 2:26 pm

Why is this not an option? "Delete this panel" is grayed out.

User avatar
hemimaniac
Level 5
Level 5
Posts: 503
Joined: Thu Feb 04, 2010 1:26 pm
Location: London ON

Re: Delete default bottom panel

Post by hemimaniac » Wed Jul 28, 2010 2:43 pm

if you are using docky or AWN you can simply remove the panel by opening gconf-editor then Desktop > Gnome > Session > and required components

take out gnome panel and insert youre manager of choice
"Linux allows for one thing above all else - 'A user can truly be themselves!'"
Image

User avatar
kindofabuzz
Level 2
Level 2
Posts: 75
Joined: Fri Jan 30, 2009 7:47 am
Location: Memphis, TN

Re: Delete default bottom panel

Post by kindofabuzz » Wed Jul 28, 2010 2:52 pm

That still doesn't tell me why I can't just delete the panel.

User avatar
hemimaniac
Level 5
Level 5
Posts: 503
Joined: Thu Feb 04, 2010 1:26 pm
Location: London ON

Re: Delete default bottom panel

Post by hemimaniac » Wed Jul 28, 2010 3:01 pm

I don't know, maybe the *buntu and Mint creators got tired of the whole "OMG please help, my panel has disappeared!" question, as you may or may not know, Mint is Based on Ubuntu, but the mint gang can't fix everything, maybe ask the panel question over there.

Also, one may always set it to hide
"Linux allows for one thing above all else - 'A user can truly be themselves!'"
Image

User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4581
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Delete default bottom panel

Post by Aging Technogeek » Wed Jul 28, 2010 3:06 pm

As a safety feature, to prevent accidental deletion of the only panel, the bottom panel cannot be deleted via the panel properties window until a second panel is added. There is the option of putting the panel in auto-hide mode, or follow hemimaniac's advice and delete the panel through gconf-editor.
Registered Linux User 483387

exhipigeonist
Level 1
Level 1
Posts: 4
Joined: Mon May 30, 2011 11:55 pm

Re: Delete default bottom panel

Post by exhipigeonist » Tue May 31, 2011 12:04 am

Hi!

I'm trying to work out how to stop the Gnome Panel starting in Mint 11(64) and noticed that gnome-panel isn't listed in the 'desktop>gnome>session>required-components' area anymore. I just want awn awl the time, and don't want an open (hidden) panel on my desktop I don't use!

Does anyone know of a simple way to stop gnome-panel from starting in Mint 11? I've heard 'Ubuntu Tweaks' may be able to do it, but I'm hesitant to install more software in order to remove something that should be fairly simple.

Habitual
Level 13
Level 13
Posts: 4870
Joined: Sun Nov 21, 2010 8:31 pm
Location: 0.0.0.0

Re: Delete default bottom panel

Post by Habitual » Tue May 31, 2011 12:23 pm

exhipigeonist:
How to fully replace your GNOME panels with AWN
See "Step 4".

go and sin no more.

david4dev
Level 1
Level 1
Posts: 44
Joined: Wed May 11, 2011 1:50 pm

Re: Delete default bottom panel

Post by david4dev » Tue May 31, 2011 2:30 pm

I've found that the trick of removing it from the required components doesn't work anymore. I don't know if this is a bug, deliberate or just me. The method I use is to create a custom session without gnome-panel. I find this works really well but there is a downside that it won't start the freedesktop autostart items (which hasn't been a problem for me).

Habitual
Level 13
Level 13
Posts: 4870
Joined: Sun Nov 21, 2010 8:31 pm
Location: 0.0.0.0

Re: Delete default bottom panel

Post by Habitual » Tue May 31, 2011 3:14 pm

We just need to Tinker Harder then! :wink:

exhipigeonist
Level 1
Level 1
Posts: 4
Joined: Mon May 30, 2011 11:55 pm

Re: Delete default bottom panel

Post by exhipigeonist » Wed Jun 01, 2011 8:21 pm

david4dev wrote:I've found that the trick of removing it from the required components doesn't work anymore. I don't know if this is a bug, deliberate or just me. The method I use is to create a custom session without gnome-panel. I find this works really well but there is a downside that it won't start the freedesktop autostart items (which hasn't been a problem for me).
Thank you! This works perfectly. I don't know what the freedesktop autostart items are, so it shouldn't be a problem for me, either.

For anyone else reading along at home, after following the helpful instructions linked above, I just went to the 'Preferences => Login Screen' window and set 'User Defined Session' to the default session. Just remember to do all these steps for each user that doesn't want gnome-panel. (There may be a way to do this universally, but these steps are more than sufficient for my computer with only two users.)

Thanks again, david4dev!

ETA: Odd. By changing the default session to 'User Defined Session' in my login, this changed the default for both users. (Not sure how this got rid of gnome-panel in the other account when the only .xinitrc file is in my own home folder they don't have access to.) This led to good results on my computer (the other account is already using awn), but it is probably good to mention that others should be careful trying this if there may be some current or future accounts on their computer who may actually want to use gnome-panel.

gurpal2000
Level 1
Level 1
Posts: 9
Joined: Fri Jun 01, 2012 2:07 pm

Re: Delete default bottom panel

Post by gurpal2000 » Thu Sep 17, 2015 6:25 pm

Is there any 2015 solution to this. It is possible to killall mate-panel but then it restarts.
I'm using an alternative (eg. tint2) but this remaining bit of panel hanging around is plain annoying.

EDIT: bit brutal but i did sudo chmod -x /usr/bin/mate-panel. System seems stable for now...

thx

bluethirdup
Level 1
Level 1
Posts: 22
Joined: Sun May 24, 2015 6:27 pm

Re: Delete default bottom panel

Post by bluethirdup » Thu Sep 17, 2015 8:52 pm

There is an answer here by passerby.

http://forums.linuxmint.com/viewtopic.p ... 6&t=145920

Code: Select all

sudo mv /usr/bin/mate-panel /usr/bin/mate-panel.old
then log out and back in. No more mate-panel on login.

Post Reply

Return to “MATE”