[SOLVED] -The Party's over... no libhid, libhid-dev, no go.

Forum rules
Before you post please read how to get help
Post Reply
User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

[SOLVED] -The Party's over... no libhid, libhid-dev, no go.

Post by rec9140 » Wed Feb 23, 2011 10:15 pm

Any one know whats the deal with the libhid, libhid-dev, and python-hid packages? ?

They are not released for maverick, thus not available for KMint 10. :twisted:

Thus software for my wx station receiver will not compile or run with out this..... :evil:

So the partys over.... can't upgrade my main desktop with out this running, and KDE 4.6.0 is the first thats usable...

Can test on my laptop... but thats it for the desktops can't upgrade home, or work.. and this interferes with other projects.... URRRGH! This is a big problem.... :twisted:
Last edited by rec9140 on Sat Feb 26, 2011 1:33 pm, edited 1 time in total.
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: The Party's over... no libhid, libhid-dev, no go.

Post by rec9140 » Wed Feb 23, 2011 11:18 pm

OK.. I've tracked down the debs from the last release and they will install and I can get the software to compile and appears to run... I am not where the wx devices are...right now to connect to see if they run correctly.

Its hard enough getting this stuff to work under Linux as it is... but.....

Really people DON'T DELETE PACKAGES, YES I AM POINTING AND LEARING AT YOU CANONICAL! NEED FROM THE REPOS! :evil: :twisted:


URRRRGGGGGGGGGGGGGGHHHHHHHHHHHHHHH! :evil:

We will see as I go to each site with this software and try it.....

Note: To KMint, you really should put these in your own repos to replace the missing ones from upstream...
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

User avatar
richyrich
Level 19
Level 19
Posts: 9075
Joined: Mon May 04, 2009 8:31 pm

Re: The Party's over... no libhid, libhid-dev, no go.

Post by richyrich » Thu Feb 24, 2011 12:15 am

Question . . can you tell me what percentage of Mint users run weather receiver stations ?
Why don't you become a package maintainer yourself ? . . . I've got some cool tutorial links & stuff if you are interested.
We're all volunteers, and we contribute where and when we can. :)

good luck, and regards, richy

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: [SOLVED] -The Party's over... no libhid, libhid-dev, no

Post by rec9140 » Sat Feb 26, 2011 1:45 pm

OK... for any one who needs to use USB HID devices here's the requisite missing DEBs for libhid0 and the dev headers you will need, along with the python interface if your using it.

You probably also will need pkg-config, so

Code: Select all

sudo apt-get install pkg-config
Extract and then install the 3 DEB's using the GDebi installer

Install in this order
libhid0
libhid0-dev
libhid-python

I've been to several of the tower sites with these wx stations and can plug my test system in and pull data from them just like the current release.

Problem solved.

These really should be in the repos, it makes no sense as to why they are not there, and I am pretty sure they were available until KMint9/Lucid, as I've had this run on a live DVD test setup to make. This happened upstream for some reason... :evil:
Attachments
libhid-dev_0.2.15+20060325-2.2ubuntu1_i386.deb.tar.gz
libhid debs
(93.88 KiB) Downloaded 359 times
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: [SOLVED] -The Party's over... no libhid, libhid-dev, no

Post by Boo » Sat Feb 26, 2011 10:27 pm

Built mint versions for amd64 and uploaded to julia-kde repo.
i386 next.
Both versions done and in julia-kde repo.

Cheers
Jamie
Image
Now where was i going? Oh yes, crazy!

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: [SOLVED] -The Party's over... no libhid, libhid-dev, no

Post by rec9140 » Sun Feb 27, 2011 8:47 am

Boo wrote:Built mint versions for amd64 and uploaded to julia-kde repo.
i386 next.
Both versions done and in julia-kde repo.
Jamie
THANK YOU ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! :D :mrgreen:
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

Post Reply

Return to “KDE”