need help recording sound card output, no mixer option

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
JaguarNight
Level 2
Level 2
Posts: 75
Joined: Sat Feb 19, 2011 3:06 pm

need help recording sound card output, no mixer option

Post by JaguarNight » Sat Feb 26, 2011 6:44 pm

Setup:
LM10 64 bit, HP laptop, intel built-in sound card,
Alsa sound framework ( default in LM10 ) http://www.alsa-project.org/main/index.php/Main_Page

Example:
If I'm on skype and I want to record a conversation for future reference, or you can record streaming sound, etc...
So typically you go into mixer application and enable mix option that will patch the sound card output into the input,
so that it could be recorded with app like Audacity, etc..
http://wiki.audacityteam.org/index.php? ... e_computer

Problem:
On this laptop the sound card or Alsa framework ( driver ) has no mixer option,
I check all possible mixer apps for linux shell and gui and could not find the mixer option.
Not sure if it's Intel sound card problem ( less likely because the card is high end laptop )
or Alsa driver problem ( more likely ) or Mixer apps that come with linux ( less likely )...

Apps I have installed:
Alsa and Pulse audio support is installed as default on LM10
Ghome alsa mixer, there is a MUX options which is checked
Kmixer - tried that too
Alsamixer - shell mixer, no mixer option
Pulse audio device chooser ( comes with LM10 )
Pulse audio volume control ( comes with LM10 )

Can't loop with output -> mike cable because built-in mike near built-in webcam is used in skype
system sound works fine
mike recording works fine, both internal and external,
line-in works fine but can't be patched to mike, it's either line-in or mike, not both ( as far as I know )

Possible solution:
I've read on the web that Pulse audio is a server/client itself that somehow
could be used to patch the sound output of one program to sound input of another, but not sure how to do it.
http://pulseaudio.org/wiki/PerfectSetup
Also read that there is another app called Jack that can do the output->input patching, but again not sure how to do it.
http://jackaudio.org/

If anybody had same problem and knows the solution or knows Pulse Audio or Jack frameworks,
please I would appreciate any pointers/solutions/info, as this is the only hardware problem I got on this laptop...

Thanks !

cjsnow1
Level 1
Level 1
Posts: 32
Joined: Thu Jul 08, 2010 11:57 am

Re: need help recording sound card output, no mixer option

Post by cjsnow1 » Fri Mar 04, 2011 12:09 pm

If you follow the tutorial on this blog here:http://drsjlazar.blogspot.com/2009/02/t ... utput.html
then it should work in Audacity.
The second you press record it should be recording your output. Very handy tut as I have been searching for a solution like this for months. :D

JaguarNight
Level 2
Level 2
Posts: 75
Joined: Sat Feb 19, 2011 3:06 pm

Re: need help recording sound card output, no mixer option

Post by JaguarNight » Wed Mar 09, 2011 5:59 pm

Thanks for the reply, but I got it figured out...

The problem is poor design of PULSE AUDIO VOLUME CONTROL app.
not very intuitive and hard to find proper settings and options...

Here is how to record your PC Sound Card audio ( any sound that the sound card produces and that comes out of speakers of headphones ):

part 1. ( the standard setup )
- install GNOME ALSA MIXER app
- open it
- select sound card tab, if there are multiple sound cards like on mine there is 1. analog 2. hdmi, then select analog default sound card
- on the mixer panel make sure REC is checked and Capture slider is not zeroed out
- make sure nothing is muted on the mixer, just in case
- check to make sure microphone recording is working ( sound recorder app or Audacity, etc... )

part 2. ( the tricky part )
- open PULSE AUDIO VOLUME CONTROL app from Sound & Video menu
note: this is not the same app that opens from standard taskbar speaker icon, but a different one
- go to Input Devices tab
- click on Show button and select Monitors
- find section which reads: Monitor of Internal Audio Analog Devices, there will be 2 sliders and 3 buttons there
- make sure mute button is not checked
- make sure Set As Fallback button is checked ***,
this setting will switch recording function from monitoring sound card output instead of microphone

To go back to recording the microphone instead of recording sound card output:
- click Show button and select All Except Monitors, microphone pane will appear
- click on "Set to Fallback" button, this will toggle the recording source back from sound card output to microphone

The short version:
'Set as Fallback" buttons in PulseAudio Volume Control app ( input devices: sound_monitors or microphone )
control which input is going to be selected for recording. With those buttons you can control recording source as
either sound card output for microphone.
*************************

Now the next step is to figure out how to record both from microphone AND sound card output, ie full duplex recording :-)

Regards.

fraxinus_63
Level 4
Level 4
Posts: 219
Joined: Fri Jan 01, 2010 2:25 pm

Re: need help recording sound card output, no mixer option

Post by fraxinus_63 » Mon Apr 18, 2011 12:32 pm

I am so relieved to have found this thread. Thanks to all concerned.

I am a relative newbie to Mint but have used Audacity for years on other distros (SUSE, PCLinuxOS) - I could not work out for the life of me how to record my sound card output until I found this. I hope that Pulse Audio will become more intuitive as time goes by, as I think many people new to Linux would have had to give up in the face of this simple task!

analogue_G
Level 1
Level 1
Posts: 5
Joined: Fri May 06, 2011 2:51 am

Re: need help recording sound card output, no mixer option

Post by analogue_G » Fri May 06, 2011 2:56 am

Thank you JaguarNight.
I was able to get Audacity to record my soundcard by following your instructions. I had been playing with PulseAudio Volume Control for about 3 hrs before I read your post. That fallback button is very misleading. How frustrating. This solution works for LMDE (I'm using LMDE10 amd64).

rajtendulkar
Level 1
Level 1
Posts: 6
Joined: Fri Jul 27, 2012 3:14 am

Re: need help recording sound card output, no mixer option

Post by rajtendulkar » Wed Nov 28, 2012 12:07 pm

great ! it worked for me as well ! :)

Post Reply

Return to “Hardware Support”