[SOLVED] Could not refresh the list of packages

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Torquemada288
Level 1
Level 1
Posts: 2
Joined: Mon Jun 06, 2011 10:01 pm

[SOLVED] Could not refresh the list of packages

Post by Torquemada288 »

Hi all,

I've encountered an issue after doing an update earlier today. If I start the Update Manager, it falls over with the following errors.

Code: Select all

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/packages.linuxmint.com_dists_katya_import_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.
Now I can't update or install any packages with Synaptic or Software Manager.
I'm running the 64bit DVD version of Katya.
Any help with this annoying problem would be much appreciated.
Last edited by Torquemada288 on Tue Jun 07, 2011 1:31 am, edited 1 time in total.

dawgdoc
Level 9
Level 9
Posts: 2741
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: Update Manager: Could not refresh the list of packages

Post by dawgdoc »

Run this terminal command

Code: Select all

sudo rm /var/lib/apt/lists/* -vf
followed by

Code: Select all

sudo apt-get update
and you should be set. (You can find other references to this fix by searching for header.)
SYSTEMS:
HP 15-bw0017cl -- Mint 19.3 Cinnamon
Compaq Presario CQ62 -- Mint 17 Cinnamon (support for 80 y/o family members 1st install)
READING:
The Secret of the Ninth Planet by Donald A. Wollheim

Torquemada288
Level 1
Level 1
Posts: 2
Joined: Mon Jun 06, 2011 10:01 pm

Re: Update Manager: Could not refresh the list of packages

Post by Torquemada288 »

dawgdoc wrote:Run this terminal command

Code: Select all

sudo rm /var/lib/apt/lists/* -vf
followed by

Code: Select all

sudo apt-get update
and you should be set. (You can find other references to this fix by searching for header.)
If I had a uterus, I'd have your babies.
Due to my pesky Y chromosome, all I can offer is my thanks. :)

dawgdoc
Level 9
Level 9
Posts: 2741
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: [SOLVED] Could not refresh the list of packages

Post by dawgdoc »

Glad to be of assistance, you are most welcome.
SYSTEMS:
HP 15-bw0017cl -- Mint 19.3 Cinnamon
Compaq Presario CQ62 -- Mint 17 Cinnamon (support for 80 y/o family members 1st install)
READING:
The Secret of the Ninth Planet by Donald A. Wollheim

biggocharley
Level 2
Level 2
Posts: 79
Joined: Fri Dec 10, 2010 5:54 pm

Re: [SOLVED] Could not refresh the list of packages

Post by biggocharley »

Followed the instructions above and got this result at the end of the "sudo apt-get update".
What is the significance of this and should I be concerned?
<W: GPG error: http://archive.ubuntu.com lucid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 40976EAF437D05B5>

By the way I'm running LMDE

dawgdoc
Level 9
Level 9
Posts: 2741
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: [SOLVED] Could not refresh the list of packages

Post by dawgdoc »

biggocharley wrote:What is the significance of this and should I be concerned?
<W: GPG error: http://archive.ubuntu.com lucid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 40976EAF437D05B5>

By the way I'm running LMDE
I'm guessing you added an Ubuntu repository or PPA for some app available of LM 9 - Isadora or Ubuntu 10.04 - Lucid Lynx because of the address of the archive. LMDE will not be prefectly compatible with Ubuntu since it is based on Debian instead of Ubuntu. Is that correct? I guess you could have edited your sources.list in some other manner.

From the LMDE release announcement
FAQ about LMDE
1. Is LMDE compatible with Ubuntu-based Linux Mint editions?

No, it is not. LMDE is compatible with Debian, which isn't compatible with Ubuntu.
2. Is LMDE fully compatible with Debian?

Yes, 100%. LMDE is compatible with repositories designed for Debian Testing ...
If you happened to have added a PPA which will work with LMDE then look to the PPAs instruction page for the Signing Key. You should be able to adapt these instructions for adding the key.
Step 5: Back on the PPA's overview page, look for the Signing key heading. You'll see something like:

1024R/72D340A3 (What is this?)

Copy the portion after the slash but not including the help link; e.g. just 72D340A3.

Step 6: Now you need to add that key to your system so Ubuntu can verify the packages from the PPA. In your terminal, enter:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 72D340A3

Replace 72D340A3 with whatever you copied in the step 5.

This will now pull down the PPA's key and add it to your system.
SYSTEMS:
HP 15-bw0017cl -- Mint 19.3 Cinnamon
Compaq Presario CQ62 -- Mint 17 Cinnamon (support for 80 y/o family members 1st install)
READING:
The Secret of the Ninth Planet by Donald A. Wollheim

Post Reply

Return to “Software & Applications”