Disable beep [SOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
artswan
Level 1
Level 1
Posts: 7
Joined: Sat Jun 25, 2011 7:26 pm

Disable beep [SOLVED]

Post by artswan »

Hello.
I have no module pcspkr loaded but I hear the beep all time (when reboot, do mistypes in console etc). I noticed that beep volume is the same as system volume, so when I make soundcard master volume louder the beep makes louder too and otherwise. I tryed to disable gnome notifications sounds but it doesn't help.
So does anybody know which module, option or some other stuff plays this ugly beep?
Last edited by artswan on Sun Jul 03, 2011 1:32 pm, edited 1 time in total.

dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable beep

Post by dagon »

try:
menu > control centre > sound > sound effects (tab)
Alert volume: check mute

artswan
Level 1
Level 1
Posts: 7
Joined: Sat Jun 25, 2011 7:26 pm

Re: Disable beep

Post by artswan »

dagon wrote:try:
menu > control centre > sound > sound effects (tab)
Alert volume: check mute
Yes it works. But I listen music and watch movies sometimes so I don't want to disable sound at all. Just want to disable beep.
BTW: I used Ubuntu and Debian before and never faced with such problem.

dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable beep

Post by dagon »


artswan
Level 1
Level 1
Posts: 7
Joined: Sat Jun 25, 2011 7:26 pm

Re: Disable beep

Post by artswan »

Thanks for your replies. But problem is not in pcspkr module. As I said I already have it blacklisted and it is not loaded. My beep plays via sound card doesn't via speaker I believe.
Ps: I found how disable beeping in console http://www.linuxquestions.org/questions ... ost3930076. Now it's better but it is not solution: I still have beep on shutdown.
Last edited by artswan on Sun Jun 26, 2011 9:26 am, edited 1 time in total.

dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable beep

Post by dagon »

sorry. I read your thread again and you clearly mentioned pcspkr.

dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable beep

Post by dagon »

What Mint edition are you using?
Is it a Laptop?

dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable beep

Post by dagon »


artswan
Level 1
Level 1
Posts: 7
Joined: Sat Jun 25, 2011 7:26 pm

Re: Disable beep

Post by artswan »

Ha!
You write it while I'm editing my message.
I'm using mint debian edition on laptop. I tryed it on desktop and there is the same problem.
I found out that it is not related to Gnome or X at all - I tryed to boot in "recovery" mode and still had the beep. So I think it plays some kernel module.
Also I found suspicious line in dmesg output:

Code: Select all

[    9.805815] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:10.1/input/input8
May it be related somehow?

dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable beep

Post by dagon »

I really haven't got a clue. AFAIK on a stationary the annoying beep comes from a little speaker that you can rip out, cut the wires to or ram a screewdriver through... problem solved! But on a laptop that is probably emulated with a soundfile. You can also untick "terminal bell" in preferences if you wan't to remove the sound in gnome terminal only.


from: http://duopetalflower.blogspot.com/2011 ... amd64.html
Anonymous said...

I'm not sure how this occurred, but after installing this kernel I now have a VERY loud and extremely annoying PC beep every time I restart my laptop (but it seems that is the only time it occurs), even if I have sound muted. I noticed that there is now an "HDA Digital PCBeep" listed among my input devices, which was never there previously. In the '/sys/devices/pci0000:00/0000:00:1b.0/input/input10' directory, there is only one subdirectory, 'input10', which is where this thing resides. The uevent provides the falling.

PRODUCT=1/111d/76b2/1
NAME="HDA Digital PCBeep"
PHYS="card0/codec#0/beep0"
PROP=0
EV=40001
SND=6
MODALIAS=input:b0001v111Dp76B2e0001-e0,12,kramls1,2,fw

Any ideas how this might have happened and/or how to permanently remove it? I've never had this occur before, and that includes your 2.6.38 kernel i installed the other day. This showed up for the very first time after installing this 2.6.38.1 kernel and rebooting. It also seems to take at least twice as long for the desktop to load after logging in on the gdm log in screen, but other than than, I'm liking it quite a bit.
March 30, 2011 8:11 PM
Sankaran Raman said...

PCBeep on connecting power cable can be disabled/enabled from bios settings. Can you see this input device listed when running 2.6.38 ?

It may have to do with patches added to 2.6.38 which is why it is 2.6.38.1

Also give 2.6.38.2 a try, liquorix kernel seems to be a good option, with kernel masters adding the config and it should work really fine,

artswan
Level 1
Level 1
Posts: 7
Joined: Sat Jun 25, 2011 7:26 pm

Re: Disable beep

Post by artswan »

Thanks a lot for help!
I believe "HDA Digital PCBeep" is the reason, I'm going to try disable it.

dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable beep

Post by dagon »

You tried alsamixer. But alsamixer doesn't have a slider for the beep thing. Gnome-alsamixer does. Try that first.
http://forums.linuxmint.com/viewtopic.p ... ep#p376201

artswan
Level 1
Level 1
Posts: 7
Joined: Sat Jun 25, 2011 7:26 pm

Re: Disable beep

Post by artswan »

:D I got it!
Install and run alsamixer and MUTE the beep (just making it 0% volume doesn't help). Found this here https://wiki.archlinux.org/index.php/Di ... eaker_Beep

artswan
Level 1
Level 1
Posts: 7
Joined: Sat Jun 25, 2011 7:26 pm

Re: Disable beep

Post by artswan »

dagon wrote:You tried alsamixer. But alsamixer doesn't have a slider for the beep thing. Gnome-alsamixer does. Try that first.
http://forums.linuxmint.com/viewtopic.p ... ep#p376201
I should refresh page before posting :) Anyway thank you.

dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable beep

Post by dagon »

Good link and fine to have it fixed. The beep-thing is just plain torture... :)

ps. Go back to the first post and add [SOLVED] to the "Subject line".

mihu
Level 1
Level 1
Posts: 1
Joined: Thu Jul 11, 2013 2:34 am

Re: Disable beep [SOLVED]

Post by mihu »

Hi, the Gnome-alsamixer solution didn't work for me, but I found elsewhere a solution that worked so I just wanted to share it in case any one would have the same problem:
You can disable this by editing a file and entering two simple lines.
gedit /etc/modprobe.d/blacklist

And then add:
#silly speaker beep
blacklist pcspkr

Save your file and the speaker beep will be gone when you reboot.
If you don’t want to wait until a reboot, simply type:
sudo rmmod pcspkr
[url]http://arsgeek.hubpages.com/hub/How-to-turn-off-the-annoying-system-beep-in-linux-DebianUbuntu[/url]
Of course it is not necessary to add the first commented line. And in LDME MATE the file was /etc/modprobe.d/alsa-base-blacklist.conf

Post Reply

Return to “Hardware Support”