[Solved] How to re-enable network notification?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
nanowire
Level 1
Level 1
Posts: 25
Joined: Thu Dec 22, 2011 1:37 pm

[Solved] How to re-enable network notification?

Post by nanowire » Thu Dec 22, 2011 2:23 pm

I installed Linux Mint 12 for the first time yesterday, and I accidentally clicked "Do not show again" on the pop-up notification that you receive at the bottom in the notification area, when you connect to a wireless network.

Now when I wake my laptop up from sleep, I get a notification that I am "Disconnected, I am now offline". (Screenshot - http://i.imgur.com/aComv.jpg ) That pop-up used to go away when the "connected to wireless network" pop-up notification appeared, but since it doesn't now, the disconnected one stays there, even though I'm connected to a wireless network at this point. The only way to get rid of the disconnected pop-up now is to click on it.

Is there a way to re-enable the notification that I disabled? Is there a whitelist / blacklist file for notifications somewhere that I can edit? I've not had any luck in finding it so far.
Last edited by nanowire on Thu Dec 22, 2011 3:20 pm, edited 1 time in total.

User avatar
mank_in
Level 6
Level 6
Posts: 1390
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: How to re-enable network notification?

Post by mank_in » Thu Dec 22, 2011 2:37 pm

Do you try network setting? If you don't see an option try use network connection .
Image
Sorry for my bad English , I am Indonesian.

nanowire
Level 1
Level 1
Posts: 25
Joined: Thu Dec 22, 2011 1:37 pm

Re: How to re-enable network notification?

Post by nanowire » Thu Dec 22, 2011 2:50 pm

mank_in wrote:Do you try network setting? If you don't see an option try use network connection .
Yes, I looked through Network Settings, Network Connection, dconf editor and Advanced Settings (for gnome3). None seem to have options for notifications. I also searched google for about an hour trying to find the config file to manually change as when I clicked "do not show again" it has to save that data somewhere but for the life of me I cannot find where it saved this setting to or how to change it back.

nanowire
Level 1
Level 1
Posts: 25
Joined: Thu Dec 22, 2011 1:37 pm

Re: How to re-enable network notification?

Post by nanowire » Thu Dec 22, 2011 3:12 pm

At this point I'd even go with disabling the "Network Disconnected - you are now offline" notification instead, at least it would be consistent that way, but oddly there is no "do not show again" option for this notification, like there was for the other.

nanowire
Level 1
Level 1
Posts: 25
Joined: Thu Dec 22, 2011 1:37 pm

Re: How to re-enable network notification? SOLVED

Post by nanowire » Thu Dec 22, 2011 3:20 pm

Ok, seems I figured this out on my own.

For anyone else interested, gconf-editor was the key.

Install via "sudo apt-get install gconf-editor", then open up gconf-editor (via terminal or in the menu it is called "Configuration Editor") and navigate to "/apps/nm-applet/". From there you can enable or disable the connected/disconnected notifications.

User avatar
darkstrike
Level 4
Level 4
Posts: 357
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: [Solved] How to re-enable network notification?

Post by darkstrike » Mon Apr 01, 2013 12:42 am

Posting a reply to an old thread, so I apologize, but I've just had the same issue as the OP in Mint 14 XFCE, however, I cannot find the "nm-applet" section in gconf-editor....where must I look in Mint 14 XFCE to re-enable network connection popups?

Thanks!

User avatar
Gas_Mask_
Level 2
Level 2
Posts: 75
Joined: Tue Feb 04, 2014 12:24 am
Location: prolly sumwhere
Contact:

Re: [Solved] How to re-enable network notification?

Post by Gas_Mask_ » Tue Feb 04, 2014 12:55 pm

Hey i had the same problem, and this forum didn't help so I made my own. "anandrkris" helped me:

"Did a quick google search and got this from the github site where Cinnamon issues / codebase is maintained.
https://github.com/linuxmint/Cinnamon/issues/2160 As per the link, the solution is

Open Terminal. Paste each of the below command and hit enter. My understanding is second one pertains your requirement,

Code: Select all

    gsettings set org.gnome.nm-applet disable-connected-notifications false
    gsettings set org.gnome.nm-applet disable-disconnected-notifications false
    gsettings set org.gnome.nm-applet disable-vpn-notifications false
"
--Gas_Mask_

User avatar
koshak83
Level 1
Level 1
Posts: 15
Joined: Sun Jan 17, 2016 5:26 pm
Location: Russian Federation, NWFD, Saint-Petersburg City

Re: [Solved] How to re-enable network notification?

Post by koshak83 » Fri Mar 18, 2016 3:51 pm

Gas_Mask_ wrote:Hey i had the same problem, and this forum didn't help so I made my own. "anandrkris" helped me:

"Did a quick google search and got this from the github site where Cinnamon issues / codebase is maintained.
https://github.com/linuxmint/Cinnamon/issues/2160 As per the link, the solution is

Open Terminal. Paste each of the below command and hit enter. My understanding is second one pertains your requirement,

Code: Select all

    gsettings set org.gnome.nm-applet disable-connected-notifications false
    gsettings set org.gnome.nm-applet disable-disconnected-notifications false
    gsettings set org.gnome.nm-applet disable-vpn-notifications false
"
THX!!! This decision helped me return the display of network notifications. :D
LMDE 2 Cinnamon x64

pwozniak
Level 1
Level 1
Posts: 2
Joined: Sun Sep 18, 2016 6:23 am

Re: [Solved] How to re-enable network notification?

Post by pwozniak » Sun Sep 18, 2016 6:24 am

Thanks for your answer Gas_Mask_
It helps me today !
Linux Mint 18.2
Cinnamon 3.4.6

User avatar
Gas_Mask_
Level 2
Level 2
Posts: 75
Joined: Tue Feb 04, 2014 12:24 am
Location: prolly sumwhere
Contact:

Re: [Solved] How to re-enable network notification?

Post by Gas_Mask_ » Fri Jan 27, 2017 3:05 pm

koshak83 wrote:
Gas_Mask_ wrote:Hey i had the same problem, and this forum didn't help so I made my own. "anandrkris" helped me:

"Did a quick google search and got this from the github site where Cinnamon issues / codebase is maintained.
https://github.com/linuxmint/Cinnamon/issues/2160 As per the link, the solution is

Open Terminal. Paste each of the below command and hit enter. My understanding is second one pertains your requirement,

Code: Select all

    gsettings set org.gnome.nm-applet disable-connected-notifications false
    gsettings set org.gnome.nm-applet disable-disconnected-notifications false
    gsettings set org.gnome.nm-applet disable-vpn-notifications false
"
THX!!! This decision helped me return the display of network notifications. :D
pwozniak wrote:Thanks for your answer Gas_Mask_
It helps me today !
Haven't been on in a long time, but I'm glad I helped in my absence
--Gas_Mask_

Perette
Level 1
Level 1
Posts: 7
Joined: Thu Jan 18, 2018 4:43 pm

Re: [Solved] How to re-enable network notification?

Post by Perette » Tue Feb 06, 2018 11:10 am

The `gsettings set` solution worked for me on LinuxMint Cinnamon 18.3.

Post Reply

Return to “Newbie Questions”