Disable Boot Splash (or lack thereof)

Suggestions and feedback for Linux Mint and the forums
Forum rules
Not support questions here please. Before you post read: Where to post ideas & feature requests
Post Reply
User avatar
A Future Pilot
Level 3
Level 3
Posts: 109
Joined: Sun May 29, 2011 9:09 am

Disable Boot Splash (or lack thereof)

Post by A Future Pilot »

I know that Linux Mint defaults to a black screen bootsplash, but some of us would really like to watch the messages scroll as the computer boots. Would it be possible in Mint 13 to have an option to easily re-enable the scrolling text?

(I personally want to figure out a way to have tux sitting on top of the scrolling text like some other distro's, but I'm not sure how to go about it :/ )
dagon
Level 7
Level 7
Posts: 1657
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Disable Boot Splash (or lack thereof)

Post by dagon »

That would probably be a good idea. Without some kind of lifesign people tend to get confused.
Ikem
Level 1
Level 1
Posts: 49
Joined: Tue Oct 25, 2011 12:29 am
Contact:

Re: Disable Boot Splash (or lack thereof)

Post by Ikem »

A Future Pilot wrote:I know that Linux Mint defaults to a black screen bootsplash,

but some of us would really like to watch the messages scroll as the computer boots.

Would it be possible in Mint 13 to have an option to easily re-enable the scrolling text?
You need to edit the kernel boot command line.

Open a terminal and type:

Code: Select all

sudo gedit "/etc/defaults/grub"
Change this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
To this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT=""
And safe the file.
lehrin
Level 1
Level 1
Posts: 1
Joined: Mon Jan 21, 2013 8:56 pm

Re: Disable Boot Splash (or lack thereof)

Post by lehrin »

I'm only resurrecting this post because I just found it on Google, and I noticed a mistake and an omission, so I figured I would point them out for others who also find it:
Ikem wrote: You need to edit the kernel boot command line.

Open a terminal and type:

Code: Select all

sudo gedit "/etc/defaults/grub"
It's actually

Code: Select all

sudo gedit /etc/default/grub
Or, in the case of MATE,

Code: Select all

sudo pluma /etc/default/grub
The next part is right on:
Ikem wrote: Change this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
To this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT=""
And safe the file.
But you need to run the following afterwards:

Code: Select all

sudo update-grub
Ikem
Level 1
Level 1
Posts: 49
Joined: Tue Oct 25, 2011 12:29 am
Contact:

Re: Disable Boot Splash (or lack thereof)

Post by Ikem »

lehrin wrote:You need to run the following afterwards:

Code: Select all

sudo update-grub
You're right. Thanks for pointing that out. :)
Zalbor
Level 4
Level 4
Posts: 320
Joined: Tue Apr 19, 2011 11:53 am

Re: Disable Boot Splash (or lack thereof)

Post by Zalbor »

To be fair, it should be gksudo and not sudo, as gedit and pluma are graphical applications.
Post Reply